Build #1

FreeRangeRouting Protocol Suite

Build: #1 was successful

Job: Debian 8 amd64 build was successful

Job result summary

Completed
Duration
22 minutes
Agent
ci1008_debian8_amd64 Proxy
Total tests
417

Tests

  • 417 tests in total
  • 2 tests were quarantined / skipped
  • 19 seconds taken in total.

Error summary

The build generated some errors. See the full build log for more details.

W: Unable to locate package debianpkg/control
mk-build-deps: Unable to find package name in `apt-cache showsrc debianpkg/control'
WARNING: this script should be executed from a git tree
configure.ac:130: installing './compile'
configure.ac:25: installing './config.guess'
configure.ac:25: installing './config.sub'
configure.ac:60: installing './install-sh'
configure.ac:60: installing './missing'
Makefile.am: installing './depcomp'
configure.ac: installing './ylwrap'
config.status: WARNING: Could not patch libtool for static linking support.  Loading modules into a statically linked daemon will fail.
mv: ‘../frr_7.1-dev-20190502-09-g5e76ce506-0.dsc’ and ‘/home/ci/cibuild.1/debwork/frr_7.1-dev-20190502-09-g5e76ce506-0.dsc’ are the same file
mv: ‘../frr_7.1-dev-20190502-09-g5e76ce506-0.debian.tar.xz’ and ‘/home/ci/cibuild.1/debwork/frr_7.1-dev-20190502-09-g5e76ce506-0.debian.tar.xz’ are the same file
dpkg-source: warning: extracting unsigned source package (frr_7.1-dev-20190502-09-g5e76ce506-0.dsc)
dpkg-source --before-build frr-7.1-dev-20190502-09-g5e76ce506
fakeroot debian/rules clean
dpkg-source -b frr-7.1-dev-20190502-09-g5e76ce506
debian/rules build
configure: WARNING: unrecognized options: --disable-maintainer-mode
config.status: WARNING: Could not patch libtool for static linking support.  Loading modules into a statically linked daemon will fail.
configure: WARNING: unrecognized options: --disable-maintainer-mode
lib/yang.c:621:1: note: #pragma message: lib/yang: time to remove non-LIBYANG_EXT_BUILTIN support
CPP_NOTICE("lib/yang: time to remove non-LIBYANG_EXT_BUILTIN support")
^
WARNING: html_favicon is not an .ico file
WARNING: html_static_path entry u'/home/ci/cibuild.1/debwork/frr-7.1-dev-20190502-09-g5e76ce506/doc/user/_static' does not exist
fakeroot debian/rules binary
libtool: install: warning: relinking `ospfclient/libfrrospfapiclient.la'
libtool: install: warning: remember to run `libtool --finish /usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: relinking `zebra/zebra_snmp.la'
libtool: install: warning: relinking `bgpd/bgpd_snmp.la'
libtool: install: warning: relinking `ripd/ripd_snmp.la'
libtool: install: warning: relinking `ospfd/ospfd_snmp.la'
libtool: install: warning: relinking `ospf6d/ospf6d_snmp.la'
libtool: install: warning: remember to run `libtool --finish /usr/lib/x86_64-linux-gnu/frr/modules'
dpkg-shlibdeps: warning: debian/frr/usr/lib/x86_64-linux-gnu/frr/modules/zebra_fpm.so contains an unresolvable reference to symbol route_top: it's probably a plugin
dpkg-shlibdeps: warning: 46 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr/usr/lib/x86_64-linux-gnu/frr/modules/zebra_irdp.so contains an unresolvable reference to symbol _rb_next: it's probably a plugin
dpkg-shlibdeps: warning: 51 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so contains an unresolvable reference to symbol route_next: it's probably a plugin
dpkg-shlibdeps: warning: 18 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 contains an unresolvable reference to symbol zlog_debug: it's probably a plugin
dpkg-shlibdeps: warning: 16 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so contains an unresolvable reference to symbol ospf_if_lookup_by_local_addr: it's probably a plugin
dpkg-shlibdeps: warning: 41 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so contains an unresolvable reference to symbol ospf6_lsa_age_current: it's probably a plugin
dpkg-shlibdeps: warning: 28 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so contains an unresolvable reference to symbol if_lookup_exact_address: it's probably a plugin
dpkg-shlibdeps: warning: 13 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so contains an unresolvable reference to symbol _hook_register: it's probably a plugin
dpkg-shlibdeps: warning: 6 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so were not linked against libdl.so.2 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so were not linked against librt.so.1 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so were not linked against libsystemd.so.0 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so were not linked against libpthread.so.0 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 was not linked against libnetsnmpmibs.so.30 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so were not linked against libcrypt.so.1 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so were not linked against libjson-c.so.2 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so were not linked against libm.so.6 (they use none of the library's symbols)
dpkg-shlibdeps: warning: debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so contains an unresolvable reference to symbol zlog_err: it's probably a plugin
dpkg-shlibdeps: warning: 36 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against librt.so.1 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libsystemd.so.0 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libdl.so.2 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libm.so.6 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libcrypt.so.1 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libjson-c.so.2 (it uses none of the library's symbols)
dpkg-gencontrol: warning: package frr: unused substitution variable ${misc:Pre-Depends}
dpkg-gencontrol: warning: package frr-snmp: unused substitution variable ${misc:Pre-Depends}
dpkg-gencontrol: warning: package frr-rpki-rtrlib: unused substitution variable ${misc:Pre-Depends}
dpkg-genchanges  >../frr_7.1-dev-20190502-09-g5e76ce506-0~deb8u1_amd64.changes
dpkg-genchanges: including full source code in upload
dpkg-source --after-build frr-7.1-dev-20190502-09-g5e76ce506
mv: cannot stat ‘cibuild.1/debwork/*.tar.gz’: No such file or directory
mv: cannot stat ‘cibuild.1/debwork/*.buildinfo’: No such file or directory