FreeRangeRouting Github Pull Request Testing

Build: #6941 was successful

Job: Debian 8 amd64 build was successful

Job result summary

Completed
Duration
17 minutes
Flags
Custom revisionCustom build
Agent
ci108_debian8_amd64 Proxy
Total tests
405
Successful since
#6920 ()

Tests

  • 405 tests in total
  • 2 tests were quarantined / skipped
  • 17 seconds taken in total.

Error summary

The build generated some errors. See the full build log for more details.

W: Unable to locate package debianpkg/control
mk-build-deps: Unable to find package name in `apt-cache showsrc debianpkg/control'
WARNING: this script should be executed from a git tree
configure.ac:130: installing './compile'
configure.ac:25: installing './config.guess'
configure.ac:25: installing './config.sub'
configure.ac:60: installing './install-sh'
configure.ac:60: installing './missing'
Makefile.am: installing './depcomp'
configure.ac: installing './ylwrap'
config.status: WARNING: Could not patch libtool for static linking support.  Loading modules into a statically linked daemon will fail.
mv: ‘../frr_7.1-dev-20190314-00-gaed536d44-0.dsc’ and ‘/home/ci/cibuild.6941/debwork/frr_7.1-dev-20190314-00-gaed536d44-0.dsc’ are the same file
mv: ‘../frr_7.1-dev-20190314-00-gaed536d44-0.debian.tar.xz’ and ‘/home/ci/cibuild.6941/debwork/frr_7.1-dev-20190314-00-gaed536d44-0.debian.tar.xz’ are the same file
dpkg-source: warning: extracting unsigned source package (frr_7.1-dev-20190314-00-gaed536d44-0.dsc)
dpkg-source --before-build frr-7.1-dev-20190314-00-gaed536d44
fakeroot debian/rules clean
dpkg-source -b frr-7.1-dev-20190314-00-gaed536d44
debian/rules build
configure: WARNING: unrecognized options: --disable-maintainer-mode
config.status: WARNING: Could not patch libtool for static linking support.  Loading modules into a statically linked daemon will fail.
configure: WARNING: unrecognized options: --disable-maintainer-mode
WARNING: html_favicon is not an .ico file
WARNING: html_static_path entry u'/home/ci/cibuild.6941/debwork/frr-7.1-dev-20190314-00-gaed536d44/doc/user/_static' does not exist
/home/ci/cibuild.6941/debwork/frr-7.1-dev-20190314-00-gaed536d44/doc/manpages/bfd-options.rst:: WARNING: document isn't included in any toctree
fakeroot debian/rules binary
libtool: install: warning: relinking `ospfclient/libfrrospfapiclient.la'
libtool: install: warning: remember to run `libtool --finish /usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: `lib/libfrr.la' has not been installed in `/usr/lib/x86_64-linux-gnu/frr'
libtool: install: warning: relinking `zebra/zebra_snmp.la'
libtool: install: warning: relinking `bgpd/bgpd_snmp.la'
libtool: install: warning: relinking `ripd/ripd_snmp.la'
libtool: install: warning: relinking `ospfd/ospfd_snmp.la'
libtool: install: warning: relinking `ospf6d/ospf6d_snmp.la'
libtool: install: warning: remember to run `libtool --finish /usr/lib/x86_64-linux-gnu/frr/modules'
dpkg-shlibdeps: warning: debian/frr/usr/lib/x86_64-linux-gnu/frr/modules/zebra_irdp.so contains an unresolvable reference to symbol if_name_head_RB_TYPE: it's probably a plugin
dpkg-shlibdeps: warning: 52 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr/usr/lib/x86_64-linux-gnu/frr/modules/zebra_fpm.so contains an unresolvable reference to symbol route_table_iter_pause: it's probably a plugin
dpkg-shlibdeps: warning: 47 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so contains an unresolvable reference to symbol listnode_add_sort: it's probably a plugin
dpkg-shlibdeps: warning: 29 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so contains an unresolvable reference to symbol rip: it's probably a plugin
dpkg-shlibdeps: warning: 16 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so contains an unresolvable reference to symbol route_next: it's probably a plugin
dpkg-shlibdeps: warning: 6 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so contains an unresolvable reference to symbol route_top: it's probably a plugin
dpkg-shlibdeps: warning: 42 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so contains an unresolvable reference to symbol sockunion_init: it's probably a plugin
dpkg-shlibdeps: warning: 19 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 contains an unresolvable reference to symbol thread_cancel: it's probably a plugin
dpkg-shlibdeps: warning: 17 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 were not linked against libcrypt.so.1 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 were not linked against libdl.so.2 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 was not linked against libnetsnmpmibs.so.30 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 were not linked against librt.so.1 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 were not linked against libjson-c.so.2 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 were not linked against libpthread.so.0 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 were not linked against libsystemd.so.0 (they use none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospf6d_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ripd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/zebra_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/ospfd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_snmp.so debian/frr-snmp/usr/lib/x86_64-linux-gnu/frr/libfrrsnmp.so.0.0.0 were not linked against libm.so.6 (they use none of the library's symbols)
dpkg-shlibdeps: warning: debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so contains an unresolvable reference to symbol prefix_new: it's probably a plugin
dpkg-shlibdeps: warning: 36 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libdl.so.2 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libcrypt.so.1 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against librt.so.1 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libjson-c.so.2 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libssh.so.4 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libm.so.6 (it uses none of the library's symbols)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/frr-rpki-rtrlib/usr/lib/x86_64-linux-gnu/frr/modules/bgpd_rpki.so was not linked against libsystemd.so.0 (it uses none of the library's symbols)
dpkg-gencontrol: warning: package frr: unused substitution variable ${misc:Pre-Depends}
dpkg-gencontrol: warning: package frr-snmp: unused substitution variable ${misc:Pre-Depends}
dpkg-gencontrol: warning: package frr-rpki-rtrlib: unused substitution variable ${misc:Pre-Depends}
dpkg-genchanges  >../frr_7.1-dev-20190314-00-gaed536d44-0~deb8u1_amd64.changes
dpkg-genchanges: including full source code in upload
dpkg-source --after-build frr-7.1-dev-20190314-00-gaed536d44
mv: cannot stat ‘cibuild.6941/debwork/*.tar.gz’: No such file or directory
mv: cannot stat ‘cibuild.6941/debwork/*.buildinfo’: No such file or directory