FreeRangeRouting Github Pull Request Testing

Build: #8353 was successful

Job: Ubuntu 18.04 ppc64le build was successful

Job result summary

Completed
Duration
10 minutes
Flags
Custom revisionCustom build
Agent
u1804-ppc-2.lab.netdef.org
Total tests
404
Successful since
#8342 ()

Tests

  • 404 tests in total
  • 2 tests were quarantined / skipped
  • 11 seconds taken in total.

Error summary

The build generated some errors. See the full build log for more details.

                             ^~
bgpd/rfapi/rfapi_vty.c:102:22: note: directive argument in the range [0, 1193046]
   snprintf(buf, len, "%dy%dd%dh", year, day, hour);
                      ^~~~~~~~~~~
In file included from /usr/include/stdio.h:862:0,
                 from ./lib/zebra.h:38,
                 from bgpd/rfapi/rfapi_vty.c:24:
/usr/include/powerpc64le-linux-gnu/bits/stdio2.h:64:10: note: ‘__builtin___snprintf_chk’ output between 7 and 19 bytes into a destination of size 10
   return __builtin___snprintf_chk (__s, __n, __USE_FORTIFY_LEVEL - 1,
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        __bos (__s), __fmt, __va_arg_pack ());
        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
bgpd/rfapi/rfapi_vty.c:104:26: warning: ‘%d’ directive output may be truncated writing between 1 and 7 bytes into a region of size between 4 and 8 [-Wformat-truncation=]
   snprintf(buf, len, "%dd%dh%dm", day, hour, min);
                          ^~
bgpd/rfapi/rfapi_vty.c:104:22: note: directive argument in the range [0, 1193046]
   snprintf(buf, len, "%dd%dh%dm", day, hour, min);
                      ^~~~~~~~~~~
bgpd/rfapi/rfapi_vty.c:104:22: note: directive argument in the range [0, 71582788]
In file included from /usr/include/stdio.h:862:0,
                 from ./lib/zebra.h:38,
                 from bgpd/rfapi/rfapi_vty.c:24:
/usr/include/powerpc64le-linux-gnu/bits/stdio2.h:64:10: note: ‘__builtin___snprintf_chk’ output between 7 and 24 bytes into a destination of size 10
   return __builtin___snprintf_chk (__s, __n, __USE_FORTIFY_LEVEL - 1,
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        __bos (__s), __fmt, __va_arg_pack ());
        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
bgpd/rfapi/rfapi_vty.c:106:28: warning: ‘%02d’ directive output may be truncated writing between 2 and 8 bytes into a region of size between 2 and 7 [-Wformat-truncation=]
   snprintf(buf, len, "%02d:%02d:%02d", hour, min, seconds);
                            ^~~~
bgpd/rfapi/rfapi_vty.c:106:22: note: directive argument in the range [0, 71582788]
   snprintf(buf, len, "%02d:%02d:%02d", hour, min, seconds);
                      ^~~~~~~~~~~~~~~~
bgpd/rfapi/rfapi_vty.c:106:22: note: using the range [-2147483648, 2147483647] for directive argument
In file included from /usr/include/stdio.h:862:0,
                 from ./lib/zebra.h:38,
                 from bgpd/rfapi/rfapi_vty.c:24:
/usr/include/powerpc64le-linux-gnu/bits/stdio2.h:64:10: note: ‘__builtin___snprintf_chk’ output between 9 and 29 bytes into a destination of size 10
   return __builtin___snprintf_chk (__s, __n, __USE_FORTIFY_LEVEL - 1,
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        __bos (__s), __fmt, __va_arg_pack ());
        ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
babeld/route.c: In function ‘update_route’:
babeld/route.c:184:34: warning: ‘n’ may be used uninitialized in this function [-Wmaybe-uninitialized]
                     (route_slots - n) * sizeof(struct babel_route*));
                     ~~~~~~~~~~~~~^~~~
babeld/route.c:169:12: note: ‘n’ was declared here
     int i, n;
            ^
WARNING: html_static_path entry u'/home/ci/cibuild.8353/debwork/frr-6.0.3-20190711-00-ga3a07f2dc/doc/user/_static' does not exist
fakeroot debian/rules binary
libtool: warning: relinking 'lib/libfrrsnmp.la'
libtool: warning: relinking 'ospfclient/libfrrospfapiclient.la'
libtool: warning: remember to run 'libtool --finish /usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: 'lib/libfrr.la' has not been installed in '/usr/lib/powerpc64le-linux-gnu/frr'
libtool: warning: relinking 'zebra/zebra_snmp.la'
libtool: warning: relinking 'bgpd/bgpd_snmp.la'
libtool: warning: relinking 'ripd/ripd_snmp.la'
libtool: warning: relinking 'ospfd/ospfd_snmp.la'
libtool: warning: relinking 'ospf6d/ospf6d_snmp.la'
libtool: warning: remember to run 'libtool --finish /usr/lib/powerpc64le-linux-gnu/frr/modules'
dpkg-shlibdeps: warning: debian/frr/usr/lib/powerpc64le-linux-gnu/frr/modules/zebra_irdp.so contains an unresolvable reference to symbol _mg_ZEBRA: it's probably a plugin
dpkg-shlibdeps: warning: 52 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr/usr/lib/powerpc64le-linux-gnu/frr/modules/zebra_fpm.so contains an unresolvable reference to symbol stream_get_getp: it's probably a plugin
dpkg-shlibdeps: warning: 47 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/powerpc64le-linux-gnu/frr/modules/ripd_snmp.so contains an unresolvable reference to symbol _hook_rip_ifaddr_add: it's probably a plugin
dpkg-shlibdeps: warning: 16 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/powerpc64le-linux-gnu/frr/modules/ospf6d_snmp.so contains an unresolvable reference to symbol if_is_pointopoint: it's probably a plugin
dpkg-shlibdeps: warning: 29 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/powerpc64le-linux-gnu/frr/modules/ospfd_snmp.so contains an unresolvable reference to symbol if_is_pointopoint: it's probably a plugin
dpkg-shlibdeps: warning: 42 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/powerpc64le-linux-gnu/frr/modules/zebra_snmp.so contains an unresolvable reference to symbol zebra_vrf_table: it's probably a plugin
dpkg-shlibdeps: warning: 6 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-snmp/usr/lib/powerpc64le-linux-gnu/frr/modules/bgpd_snmp.so contains an unresolvable reference to symbol sockunion_same: it's probably a plugin
dpkg-shlibdeps: warning: 19 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/frr-rpki-rtrlib/usr/lib/powerpc64le-linux-gnu/frr/modules/bgpd_rpki.so contains an unresolvable reference to symbol list_new: it's probably a plugin
dpkg-shlibdeps: warning: 36 other similar warnings have been skipped (use -v to see them all)
dpkg-genbuildinfo
dpkg-genchanges  >../frr_6.0.3-20190711-00-ga3a07f2dc-0~ubuntu18.04.1_ppc64el.changes
dpkg-genchanges: info: including full source code in upload
dpkg-source --after-build frr-6.0.3-20190711-00-ga3a07f2dc
mv: cannot stat 'cibuild.8353/debwork/*.tar.gz': No such file or directory