FRR
FRRouting
Tests: 8796 passed
Duration: 172 minutes
Changes: Who: Donald Sharp
Why: bgpd: Invalid NH"s should send an apropriate reason code
RFC 4271 sec 6.3 p33, In the case of a BGP_NEXTHOP attribute with an
incorrect value, FRR is supposed to send a notification
and include "Corresponding type, length and value of the NEXT_HOP
attribute in the notification data.

Fixes: #4997
Signed-off-by: Nikos <ntriantafillis@gmail.com>
Signed-off-by: Donald Sharp <sharpd@cumulusnetworks.com>

Who: Martin Winter
Why: Merge pull request #5024 from donaldsharp/send_that_error_bgp
bgpd: Invalid NH"s should send an apropriate reason code
debian-experimental
FRRouting - FRR
Tests: 7056 passed
Duration: 130 minutes
Changes: Who: David Lamparter
Why: debian: release 7.1-1
Signed-off-by: David Lamparter <equinox@diac24.net>

Who: David Lamparter
Why: Merge tag "frr-7.1" into debian/experimental
FRRouting Release 7.1

Who: David Lamparter
Why: Merge tag "frr-7.0.1" into debian/experimental
FRRouting Release 7.0.1

Who: David Lamparter
Why: debian: release 7.0.1-1
Signed-off-by: David Lamparter <equinox@diac24.net>
Changes by David Lamparter
debian-master
FRRouting - FRR
Tests: 6852 passed
Duration: 120 minutes
Changes: Who: David Lamparter
Why: debian: remove outdated patches
All of these were merged upstream or superseded by something else.

Signed-off-by: David Lamparter <equinox@diac24.net>

Who: David Lamparter
Why: debian: release 6.0.3-1
Signed-off-by: David Lamparter <equinox@diac24.net>

Who: David Lamparter
Why: Merge tag "frr-6.0.3" into debian/master
FRRouting Release 6.0.3
Changes by David Lamparter
dev-7.2
FRRouting - FRR
Tests: 8790 passed
Duration: 182 minutes
Changes: Who: Donald Sharp
Why: Merge pull request #5014 from idryzhov/7.2-fix-vtysh-prefix-list
[7.2] vtysh: fix multiple "no ip/ipv6 prefix-list sequence-number" lines in running-config
Changes by Donald Sharp
revert-3775-ospf_missing_interface_handling_2
FRRouting - FRR
Tests: 7557 passed
Duration: 100 minutes
Changes: No changes
First build for this plan
stable-2.0
FRRouting - FRR
Tests: 3571 passed
Duration: 80 minutes
Changes: Who: Martin Winter
Why: FRR Release 2.0.2
This version of FRR contains these fixes since the last release:
1. Improved Packaging for debian related builds.
2. Fix for a invalid AS-PATH length in BGP.
3. Fix for miss-handling of BGP attributes in an error situation.

(Re-Release of 2.0.1 which missed some version number and changelog updates)

Signed-off-by: Martin Winter <mwinter@opensourcerouting.org>
Changes by Martin Winter
stable-3.0
FRRouting - FRR
Tests: 2912 passed
Duration: 101 minutes
Changes: Who: Martin Winter
Why: FRRouting Release 3.0.4
Changes since 3.0.3:
- Security Issue (Denial of Service): Fix BGP Attribute 255 (experimental
   VNC) handling
- ospfd: allow multiple options in the redistribute command

Signed-off-by: Martin Winter <mwinter@opensourcerouting.org>
Changes by Martin Winter
stable-4.0
FRRouting - FRR
Tests: 3257 passed
Duration: 109 minutes
Changes: No changes
Manual run by Martin Winter
stable-5.0
FRRouting - FRR
Tests: 7506 passed
Duration: 120 minutes
Changes: Who: Donald Sharp
Why: Merge pull request #4596 from ton31337/fix/force_ehne_if_peer_group_and_interface_5.0
bgpd: [5.0] interface based peers should automatically override it"s peer g…
Changes by Donald Sharp
stable-6.0
FRRouting - FRR
Tests: 7291 passed
Duration: 119 minutes
Changes: Who: Donald Sharp
Why: bgpd: Add "no set as-path prepend last-as X" command
The `set as-path prepend last-as X` command had no, "no" form
of the command.  Add this into the cli.

Testing:
!
route-map BLARBLE permit 10
set as-path prepend last-as 3
!
!
router bgp 9999
neighbor 10.50.12.118 remote-as external
neighbor 10.50.12.118 ebgp-multihop 30
!
address-family ipv4 unicast
  neighbor 10.50.12.118 route-map BLARBLE in
!
!

eva# show bgp ipv4 uni 4.4.4.4
BGP routing table entry for 4.4.4.4/32
Paths: (1 available, best #1, table default)
  Advertised to non peer-group peers:
  10.50.12.118
  999 999 999 999
    10.50.12.118 from 10.50.12.118 (10.50.12.118)
      Origin incomplete, metric 0, valid, external, best (First path received)
      Last update: Mon Aug 26 09:47:17 2019

eva# conf
eva(config)# route-map BLARBLE permit 10
eva(config-route-map)# no set as-path prepend last-as 3
eva(config-route-map)# end
eva# clear bgp ipv4 uni *
eva# show bgp ipv4 uni 4.4.4.4
BGP routing table entry for 4.4.4.4/32
Paths: (1 available, best #1, table default)
  Advertised to non peer-group peers:
  10.50.12.118
  999
    10.50.12.118 from 10.50.12.118 (10.50.12.118)
      Origin incomplete, metric 0, valid, external, best (First path received)
      Last update: Mon Aug 26 09:48:31 2019

Signed-off-by: Donald Sharp <sharpd@cumulusnetworks.com>

Who: Donald Sharp
Why: Merge pull request #4901 from ton31337/fix/no_aspath_prepend_last_6.0
bgpd: [6.0] Add "no set as-path prepend last-as X" command

Who: Donald Sharp
Why: bgpd: Update doc for some as-path route-map commands
Update the documentation for some as-path route-map commands.

Signed-off-by: Donald Sharp <sharpd@cumulusnetworks.com>
Changes by Donald Sharp
stable-7.0
FRRouting - FRR
Tests: 8264 passed
Duration: 131 minutes
Changes: Who: Donald Sharp
Why: Merge pull request #4961 from ton31337/fix/check_if_rmap_exists_before_warning_7.0
bgpd: [7.0] `neighbor X:X::X default-originate` complains about (null)

Who: Donald Sharp
Why: bgpd: `neighbor X:X::X default-originate` complains about (null)
The `neighbor X:X::X default-originate command is complaining
that:
The route-map "(null)" does not exist.

Upon inspection of the code we were passing a NULL
string to the lookup.  Testing for null gets us this:

donna.cumulusnetworks.com# conf t
donna.cumulusnetworks.com(config)# router bgp 99
donna.cumulusnetworks.com(config-router)# neighbor 2001:1::1:2 remote-as 99
donna.cumulusnetworks.com(config-router)# neighbor 2001:1::1:2 default-originate
donna.cumulusnetworks.com(config-router)# end
donna.cumulusnetworks.com# show run
Building configuration...

Current configuration:
!
frr version 7.2-dev
frr defaults datacenter
hostname donna.cumulusnetworks.com
log stdout
no ipv6 forwarding
!
ip route 4.5.6.7/32 10.50.11.4
!
router bgp 99
neighbor 2001:1::1:2 remote-as 99
!
address-family ipv4 unicast
  neighbor 2001:1::1:2 default-originate

Signed-off-by: Donald Sharp <sharpd@cumulusnetworks.com>
Changes by Donald Sharp
stable-7.1
FRRouting - FRR
Tests: 8518 passed
Duration: 140 minutes
Changes: Who: Donald Sharp
Why: bgpd: `neighbor X:X::X default-originate` complains about (null)
The `neighbor X:X::X default-originate command is complaining
that:
The route-map "(null)" does not exist.

Upon inspection of the code we were passing a NULL
string to the lookup.  Testing for null gets us this:

donna.cumulusnetworks.com# conf t
donna.cumulusnetworks.com(config)# router bgp 99
donna.cumulusnetworks.com(config-router)# neighbor 2001:1::1:2 remote-as 99
donna.cumulusnetworks.com(config-router)# neighbor 2001:1::1:2 default-originate
donna.cumulusnetworks.com(config-router)# end
donna.cumulusnetworks.com# show run
Building configuration...

Current configuration:
!
frr version 7.2-dev
frr defaults datacenter
hostname donna.cumulusnetworks.com
log stdout
no ipv6 forwarding
!
ip route 4.5.6.7/32 10.50.11.4
!
router bgp 99
neighbor 2001:1::1:2 remote-as 99
!
address-family ipv4 unicast
  neighbor 2001:1::1:2 default-originate

Signed-off-by: Donald Sharp <sharpd@cumulusnetworks.com>

Who: Donald Sharp
Why: Merge pull request #4960 from ton31337/fix/check_if_rmap_exists_before_warning
bgpd: [7.1] `neighbor X:X::X default-originate` complains about (null)
Changes by Donald Sharp